Ranter
Join devRant
Do all the things like
++ or -- rants, post your own rants, comment on others' rants and build your customized dev avatar
Sign Up
Pipeless API
From the creators of devRant, Pipeless lets you power real-time personalized recommendations and activity feeds using a simple API
Learn More
Comments
-
Flygger19817yIf your language is case sensitive, abuse it?
Add a "1" after all the names you've used?
Spell them backwards? -
Agred20367yMake your code cleaner and have fun by creating variables like:
"fuckingIdiot" or "shiteVar".
Also I tend to make my code faster when boss is pissing me off and chevying me by creating git messages like "gotta go faster" and adding Sanic ASCII drawing. This only works if you are only person on the project though. -
Flygger19817yIt is a real problem though; some (more or less) critical legacy systems still running are developed in languages or on systems that put restrictions on these kinds of things (for good reasons, at least originally) so you have a fixed size and character set for variable names (typically compiler limitation e.g. https://ibm.com/support/...)
I've seen horrible legacy code, that wasn't horrible by choice, but both file and variable names we're limited to 8 alphanumerical ASCII characters (of course case insensitive) -
@wokeRoach Not to forget a method name: nsgbadcafbdhlitnafvygGxhadbsgmtabsfnwtbsfbwtbyfjdznfantemde
-
Flygger19817y@PrivateGER not if all other naming is vastly different from that naming scheme — if you really wanna fuck with people, just MD5 all the names you'd usually use ;)
-
@DefiniteGoose "Error: Variable already declared. Remove declaration or change variable name."
-
Flygger19817y@joas my solution has the added bonus to the "nonsensical" combination of characters, that it's using a very limited character set and a fixed width to further inhibit memorisation :)
-
Flygger19817y@PrivateGER sure, that would make it much harder to find out what the original variable names might actually have been, but if I were to do it in practice, either by IDE plugin, obfusc...eh...build script, git hook, or what have you, it would improve throughput and performance to your own big benefit to use a simple hashing algorithm that is optimised for speed ;)
Out of variable names
rant